Hi everyone,

I have a very frustrating and strange issue.

I have been flush setting into 3mm brass, everything has been going fine until it now.

I try to drill into the metal, with barely any luck, it will hardly drill, I figured my drill bits were blunt so I bought some new bits.

They still won't drill through. As if they are also blunt, but they aren't. ( I can get about half way after a long while of different bits)

I have been using a dremel stylo and it has been going fine until now, but I tried a different dremel just incase, still won't work.

I tried a different piece of 3mm brass - won't work.

I have tried applying different amounts of pressure - different speeds - lube - no lube - I still am strugging to make a hole through.

The past few holes have gone swimmingly using a 0.5mm then a 0.7mm then a 1mm drill bit (I found it easier to start tiny) and so on, but now nothing works, no matter what.

I cannot figure out what is going wrong. Please help. I am getting so frustrated

Thank you in advance if anyone has any idea what is going on!