Results 1 to 3 of 3

Thread: Rust color after oxidizing and finishing?!?!

  1. #1
    Join Date
    Nov 2019
    Posts
    8

    Question Rust color after oxidizing and finishing?!?!

    Hey y'all,

    I made these sterling silver stud earrings last night, and only noticed this rust-like color in the morning light when i went to take the photo.
    What's going on??? I used Midas gel LOS (like i have plenty of times), tumbled, buffed and polished. Everything was the same process as usual but I've never seen this appear before... any idea what happened, if i can fix it, and how to avoid it from happening in the future? THANKS!

    Click image for larger version. 

Name:	File_000(14).jpg 
Views:	18 
Size:	15.8 KB 
ID:	12825

  2. #2
    Join Date
    Dec 2009
    Location
    Central London
    Posts
    8,201

    Default

    It looks like the remains of the dark patina, which was not removed by tumbling, and missed in the evening light. Tumble for longer, or rub with a silver polishing cloth and it should go.Dennis.

  3. #3
    Join Date
    Nov 2019
    Posts
    8

    Default

    Quote Originally Posted by Dennis View Post
    It looks like the remains of the dark patina, which was not removed by tumbling, and missed in the evening light. Tumble for longer, or rub with a silver polishing cloth and it should go.Dennis.
    Thanks, Dennis! I'll try that.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •